CHAPTER9

MATLAB
FUZZY LOGIC TOOLBOX

Fuzzy Sets shavandi@sharif.edu

Fuzzy Logic Toolbox Graphical User Interface Tools

(B
o You can use five primary GUI tools for building,

editing, and observing fuzzy inference systems in the
toolbox:

o Fuzzy Inference System (FIS) Editor
o Membership Function Editor

o Rule Editor

o Rule Viewer

o Surface Viewer
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Fuzzy Logic Toolbox Graphical User Interface Tools
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Membership

Rule Editor Function Editor

Inference

Rule Viewer Surface Viewer
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The FIS Editor
(e

) FIS Editor: Untitled =10 x|
File Edit  WView
Untitled
(mamdani}
input! outputt
FIS Matne: Unditled FIS Type: mamdani ‘
Ancd method min - Current Yariable
O methord p— -1 || Mame inputt
T Ut
Implicstion min - ype np!
Range [01]
Annregation max -

Defuzzification I centroid - I ‘ Help Close | ‘

System "Untitled": 1 input, 1 output, and O rules ‘
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The FIS Editor
[

o The FIS Editor displays information about a fuzzy inference
system. To open the FIS Editor, type the following command at
the MATLAB prompt: fuzzy

Menu commands for Double-click an input
saving, opening, or editing variable icon to open the
afuzzy system. Wembership Function Editor.

) FIS Editor: tipper
File Edit ‘View

XX~
|

=181 %]

service

3O

food

FIS Natne: tipper FIS Type: lamam/]__

Double-click the Double-click the output
system diagram to variable icon to open the
open the Rule Editor. Membership Function Editor.
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The FIS Editor
Name of the system.
Change it using the
Save as... command.
oo
T FIS Marme: tipper FIS Type: matndani ‘
And methad I min = I Current Variable
Or methoc Iﬁm = Name tip l
Implication I min = | ol
Range (030
Aggregation Im = |
Defuzzification [eommon =] | Help cose| | ‘
‘System "tipper": 2 inputs, 1 output, and 3 rules - ‘
OPetiuns for adjusting the fuzzy Status line describes Name of the selected input
inference functions, such the most recent operation. or output variables.
as the defuzzification method.
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The FIS Editor
[

o1 The generic untitled FIS Editor opens, with one input labeled input1, and
one output labeled outputl.

0 To add a second input variable and change the variable names to reflect
these designations:
Select Edit > Add variable > Input.
A second yellow box labeled input2 appears.
Click the yellow box inputl. This box is highlighted with a red outline.
Edit the Name field from input1 to service, and press Enter.
Click the yellow box input2. This box is highlighted with a red outline.
Edit the Name field from input2 to food, and press Enter.
Click the blue box outputl.
Edit the Name field from output1 to tip, and press Enter.
Select File > Export > To Workspace.

Enter the Workspace variable name tipper, and click OK.
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The Membership Function Editor

0 The Membership Function Editor is the tool that lets you display
and edit all of the membership functions associated with all of
the input and output variables for the entire fuzzy inference
system. The Membership Function Editor shares some features
with the FIS Editor, as shown in the next figure. In fact, all of
the five basic GUI tools have similar menu options, status lines,
and Help and Close buttons.

0 You can open the Membership Function Editor in one of three
ways:
Within the FIS Editor window, select Edit > Membership Functions..
Within the FIS Editor window, double-click the blue icon called tip.

At the command line, type mfedit.
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The Membership Function Editor
[

Menu commands for "Variable Palette" area.
saving, opening, and editing Click a variable to edit its
a fuzzy system. membership functions.

J Membership Function Editor: tipper i : & |EI|1|

File Edit Wiew

FISVariahIes/ Membership function plots  PIot points: 181

m — poor good excellert

SErvice tip

XX

ool

Graph displays all Click a line to change its attributes,

membership functions such as name, type, and numerical parameters.

for the selected variable. Drag the curve to move it or to change its shape.
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The Membership Function Editor
[

Set the display range
of the current plot.

Set the range Name and tyge of
of the current variable. current variable
= =
Currert Yariable / Current Membership Function (click on MF to select)

Narne service Name I good
Type input Tyee [ooussmt | -]

ri

Params
= Range | [010] II“{S Sl !/
Displary Range W | Help / | / Close | ‘

i Fi
= y— |
7 7z
This status line Change the numerical Select the tyge of Edit name of current
describes the most parameters for current current membership  membership function.
recent operation. membership function. function.
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The Rule Editor
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The Rule Editor

To call up the Rule Editor, go to the Edit menu and select Rules, or type
rule edit at the command line.

Constructing rules using the graphical Rule Editor interface is fairly self
evident. Based on the descriptions of the input and output variables defined
with the FIS Editor, the Rule Editor allows you to construct the rule statements
automatically, From the GUI, you can:

Create rules by selecting an item in each input and output variable box, and one
Connection item and clicking Add Rule. You can choose none as one of the variable
qualities to exclude that variable from a given rule and choose not under any
variable name to negate the associated quality.

Delete a rule by selecting the rule and clicking Delete Rule.
Edit a rule by changing the selection in the variable box and clicking Change Rule.

Specify weight to a rule by typing in a desired number between O and 1 in Weight.
If you do not specify the weight, it is assumed to be unity (1).




The Rule Viewer

The Rule Viewer displays a =1ofx|

File Edit Wiew Options

roadmap of the whole fuzzy
inference process. It is based on

service =3 tood =5
. . tip=15
the fuzzy inference diagram i

described in the previous section. 1

You see a single figure window
with 10 plots nested in it. The 2 ‘
three plots across the top of the —_—
figure represent the antecedent 3
and consequent of the first rule.

Each rule is a row of plots, and ‘
each column is a variable. The

rule numbers are displayed on

the left of each row. You can click

on a rule number to view the rule
in the status line.

nput: = o Plot poirts: Fm Mave: et | right downl up |
L Spmpuam— Y ‘ ‘ Helo close |

The Rule Viewer

Upon opening the Surface PYEEE——— _{oj x|
Viewer, you see a three- Re R D G

dimensional curve that represents
the mapping from food and
service quality to tip amount.
Because this curve represents a 5
two-input one-output case, you i W T\ K e
can see the entire mapping in ""';““““:”
one plot. When we move beyond

three dimensions overall, we start

. . 0o ;
to encounter trouble displaying faad sarvice
the results. X (input): [cervies -] ¥ (outy: [[food | Z (outputy ™ 5

Kt 15 ¥ g 15 Eveiae
Ref. Input: HPIut paints; Fm || Help Close |

= |




Importing and Exporting from the GUI Tools

When you save a fuzzy system to a file, you are saving an
ASCII text FIS file representation of that system with the file
suffix .fis. This text file can be edited and modified and is
simple to understand. When you save your fuzzy system to the
MATLAB workspace, you are creating a variable (whose name
you choose) that acts as a MATLAB structure for the FIS system.
FIS files and FIS structures represent the same system.

Note:

If you do not save your FIS to a file, but only save it to the
MATLAB workspace, you cannot recover it for use in a new
MATLAB session.

Summary

Basic steps for developing Fuzzy Inference Systems using FIS:

Entering Fuzzy Logic Toolbox Graphical User Interface Tools by calling FIS Editor
Typing and entering the command “fuzzy “at the MATLAB prompt

Defining input and output variables and editing FIS properties from FIS editor

Defining Membership functions for variables using Membership Function Editor
Calling Membership Function Editor from FIS editor, edit menu

Defining rules from Rules Editor
Calling Rules Editor from FIS editor, edit menu

Viewing and checking rules and results from Rules Viewer
Calling Rules Viewer from FIS editor, view menu

Checking and analyzing results from Surface Viewer

Calling Surface Viewer from FIS editor, view menu
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Example: Washing Machine Fuzzy System

Now we develop a fuzzy inference system using MATLAB
Fuzzy Logic Toolbox for a washing machine.

In this system we decide about the length of washing time
according to the grade of dirtiness and type of dirtiness of
the clothes.

We follow the basic steps for developing fuzzy inference
systems using FIS as described before:

Entering Fuzzy Logic Toolbox Graphical User Interface Tools

by calling FIS Editor
Typing and entering the command “fuzzy “at the MATLAB prompt
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Washing Machine Fuzzy System

FIS Editor: Untitled2 E==E=m==
File Edit View
Untitled2
({mamdani)
input1 output1
FIS Mame: Untitled2 FIS Type: mamadani
And method min - Current Variable
or method max L || MName inputt
Implication min - Type M
" || Range [01]
Agoregation max -
Defuzzification centraid - Help Close | |
System "Urtitlec2" 1 input, 1 output, and O rules |

Washing Machine Fuzzy System

Defining input and output variables and editing FIS
properties from FIS editor

Input Variables:
Grade of dirtiness

Type of dirtiness

Output Variable:
Washing Time




Washing Machine Fuzzy System

B F1S Editor: 1 ==

File Edit View

1

(mamdani)
‘ FIZ Mame: 1 FIS Type: mamdani
And method min | | | Current Variable
Or methad max || [Washing_time
Implication min - Tye output
Range m1]
Aggregation max -
Defuzzification centroid - Help Close | ‘
Saved FIS ""to file ‘

Washing Machine Fuzzy System

Defining Membership functions for variables using Membership Function Editor

Calling Membership Function Editor from FIS editor, edit menu

Grade of dirtiness: Range: 0-100
Small : Triangular M.F. (-50,0,50)
Medium: Triangular M.F. (0,50,100)
Large: Triangular M.F. (50,100,150)

Type of dirtiness: Range: 0-100
Not Greasy: Triangular M.F. (-50,0,50)
Medium: Triangular M.F. (0,50,100)
Greasy: Triangular M.F. (50,100,150)

Washing Time: Range: 0-60
Very Short: Triangular M.F. (6,8,10)
Short: Triangular M.F. (9,12,15)
Medium: Triangular M.F. (16,20,24)
Long: Triangular M.F. (34,40,46)
Very Long: Triangular M.F. (5,060,70)
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Washing Machine Fuzzy System

File Edit View

FIS Variables

LA

srade_f irtin&¢ash ing,ime:

[ypeoldlmn £55

ll Membership Function Editor: 1

(=] ]
Membership function plots  PIet peints: 181
sHeary hort Medium Long eny ong

AN

output variable "Wash mg[\ma"

Current Variakle
Mame

Type

Ranoe

Display Range

Washing_time

output

[080]

[080]

Currert Membership Function (click on MF to select)

Mame Very_Short
Type trimf

Params 91215

| Help Close |

Selected variable "Washing_time"

Washing Machine Fuzzy System

Defining rules from Rules Editor

Calling Rules Editor from FIS editor, edit menu

If Grade of dirtiness is (Small) and Type of dirtiness is (Not Greasy) then Washing time

is (Very Short).

If Grade of dirtiness is (Small) and Type of dirtiness is (Medium) then Washing time is

(Short).

If Grade of dirtiness is (Medium) and Type of dirtiness is (Not Greasy) then Washing

time is (Short).

If Grade of dirtiness is (Medium) and Type of dirtiness is (Medium) then Washing time

is (Medium).

If Grade of dirtiness is (Large) and Type of dirtiness is (Medium) then Washing time is

(Long).

If Grade of dirtiness is (Medium) and Type of dirtiness is (Greasy) then Washing time is

(Long).

If Grade of dirtiness is (Large) and Type of dirtiness is (Greasy) then Washing time is

(Very Long).
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Washing Machine Fuzzy System

B Rule Editor: 1
File Edit View Options

= ]

If {(Grade_of_dirtiness is Large) and (Type_of_dirtiness is Medium) then (Washing_time is

Nmo s o

If {(Grade_of_dirtiness is Large) and (Type_of_dirtiness is Greasy) then (Washing_time is

4 .

If (Grade_of_dirtiness is Small) and (Type_of_dirtiness is MotGreasy) then (Washing_time is Very_Short) .
If {(Grade_of_dirtiness is Small) and (Type_of_diftiness is Medium) then (Washing_time is Short) (1)

If {(Grade_of_dirtiness is Medium) and (Type_of_dirtiness is NotGreasy) then (Washing_time is Short) (1)

If {(Grade_of_dirtiness is Medium) and (Type_of_dirtiness is Medium) then (Washing_time is Medium) (1)

If {(Grade_of_dirtiness is Medium) and (Type_of_dirtiness is Greasy) then (Washing_time is Long) (1)

Long) (1)

Very_Long) (1]

It ani
Grade_of_dirtines Type_of_dittiness

~
Medium IMedium

Large Greasy

none none

[ nat [ net

~ Connection Wigight:

(") or

0 and 1 Delste rule Addrie | Changerie |

d Then
Washing_time is

<2

The rule is changed | | Help Close |

Washing Machine Fuzzy System

Viewing and checking rules and results from Rules

Calling Rules Viewer from FIS editor, view menu

Viewer

B Rule Viewer 1 =]
File Edit View Options
Grade_of_dirtiness = 50 Type_of_dirtiness = 50 Washing_time = 20
, | -] ] (A1
: | ]
o | | L] ]
| | I
o | | | [ A]
o | | | [ A
il [ L]
0 60
[T p—— HPIUI points: 4 ‘ Move: et | right | down| up ‘
‘ Opened system 1, 7 rulss ‘ | Help Close ‘
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Washing Machine Fuzzy System
[

6. Checking and analyzing results from Surface Viewer

Calling Surface Viewer from FIS editor, view menu

B suiface Viewer 1 (== Eoh =

File Edit View Options

wiashingjme

Type,fjrtiness

Gradle f jtiness

3 (input) Grade_of_d.. » Y (nputk Type_of dir.. ~ ZCoutput) Washing_time

X grids: 15 ¥ grids: 15 Evaluate
Ret. Input HPM points: 4 nq | | Help Close ‘

Reacly
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